Some members are not seeing Club Peloton discounts on Apparel website

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 10:01 EDT

Identified

Team is has identified that some members are unable to see their Club Peloton discounts on our Apparel website. Team is working to enable Club Peloton Apparel discounts for those members who currently do not see it.
Posted Oct 06, 2025 - 15:52 EDT
This incident affected: Website (Peloton Apparel (apparel.onepeloton.com)).