Members experiencing Update Card Errors
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 20, 2019 - 17:26 EDT
Investigating
Members may receive error messages when updating their credit card information. We apologize for any inconvenience and we appreciate your patience while we investigate this matter.
Posted about 2 months ago. Aug 20, 2019 - 11:24 EDT
This incident affected: Rider Profile/Workout History.