Primary Phones Not Workign
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 10:08 EDT
Monitoring
After working with our telephony partners, we have identified the issue and implemented a fix and our teams should now be reachable by phone. We will continue to monitor and update this page accordingly.
Posted Sep 09, 2020 - 09:59 EDT
Update
We are continuing to investigate this issue.
Posted Sep 09, 2020 - 09:20 EDT
Investigating
We are currently investigating an issue with our primary telephone number that is causing incoming calls not to connect. you can purchase all of our products, including the new Bike+, or chat with our Sales team on our website at www.onepeloton.com. For support, our team can be contacted by Chat at support.onepeloton.com.
Posted Sep 09, 2020 - 09:08 EDT
This incident affected: Contact (Phone).