Issue accessing members.onepeloton.com

Incident Report for Peloton

Resolved

The issues with accessing members.onepeloton.com, logging in, and accessing content via WebTV and Chromecast have all been successfully resolved.
Posted Sep 29, 2023 - 10:43 EDT

Monitoring

The team is actively investigating an issue where some Members cannot access members.onepeloton.com.
Posted Sep 29, 2023 - 10:28 EDT
This incident affected: Website (Peloton Profile/Workout History (members.onepeloton.com)).