Errors on Scheduling Delivery Page
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Nov 30, 2024 - 10:58 EST
Monitoring
All members should now be able to resume scheduling their deliveries.

If a member encountered an error between 9:30am - 5:45pm EST, we recommend members scheduled their delivery via the link in their order confirmation email or access through the order status page (https://account.onepeloton.com/orderhistory). Members will also receive a reminder email to schedule the delivery if no delivery is schedule. We apologize for the inconvenience.
Posted Nov 29, 2024 - 18:15 EST
Update
Some members will see an error message when attempting to schedule their delivery, at this time those members will not be able to schedule delivery, we apologize for the inconvenience.

Once this issue is resolved with our delivery partners members will be able to schedule via the link in their order confirmation email or accessing order status page (https://account.onepeloton.com/orderhistory), otherwise a reminder email will be sent to schedule the delivery.

Team is working with our partner to resolve the issue.
Posted Nov 29, 2024 - 15:24 EST
Identified
Some members when scheduling their delivery may receive a "hmmm, it looks like that slot is not available" error message due to an issue with a delivery partner.

This does not mean the date has not been scheduled, we advise members to check https://account.onepeloton.com/orderhistory to see their confirmed delivery time. If member's order was not scheduled, a reminder email will be sent to schedule the order.

Team is working with our partner to resolve the issue.
Posted Nov 29, 2024 - 12:34 EST