Some Members Unable to Log in to Peloton

Incident Report for Peloton

Resolved

This issue has been resolved.

We observed an 8 minute period of elevated 503’s from a vendor system resulting in some auth instability.
Posted Apr 22, 2026 - 18:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 14:56 EDT

Investigating

Team is investigating an issue impacting the ability to log into Peloton across all platforms.
Posted Apr 22, 2026 - 14:48 EDT
This incident affected: Bike/Tread/App/Row (Member Login).