Our Repair Scheduling service is currently down impacting our agents' ability to schedule repairs.

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 21:10 EDT

Monitoring

The team has rolled out a fix to prevent current and future issues with scheduling repair appointments. If you observe any additional problems, please contact Member Support for further assistance.
Posted Jun 18, 2025 - 13:28 EDT

Investigating

We are currently investigating this issue. Please check your scheduling link within the next 24 hours to set a date for your appointment.
Posted Jun 17, 2025 - 12:57 EDT