Leaderboard Slow to Load
Incident Report for Peloton
Resolved
We have resolved the issue with the leaderboard slow to load/filter for rides taken between 7:00-7:45 PM ET. Classes taken during this time may have issues with the workout history displaying accurately during this time.
Posted about 1 year ago. Oct 09, 2018 - 20:08 EDT
Investigating
We are investigating an issue with the live and on-demand leaderboard being slow to load. This may impact your ability to view and filter the leaderboard and give and receive high-fives.
Posted about 1 year ago. Oct 09, 2018 - 18:45 EDT
This incident affected: Bike/Tread (Live Classes, On Demand Classes).