Personalized Plans module missing

Incident Report for Peloton

Resolved

This issue has been resolved.
Posted Jul 21, 2025 - 09:28 EDT

Monitoring

The personalized plans module was identified this morning missing on the Homescreen. A fix has been implemented. If members are still experiencing issues please restart the app.
Posted Jul 21, 2025 - 09:23 EDT
This incident affected: Bike/Tread/App/Row (Peloton App).