Affirm Integration Interruption
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 17:52 EDT
Investigating
We are investigating an issue with financing purchases using Affirm. Some Members have reported success trying to check out a second time.
Posted Jun 13, 2023 - 17:12 EDT
This incident affected: Integrations (Affirm).