Live Class Streaming Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted May 04, 2020 - 10:27 EDT
Monitoring
Due to technical issues, Olivia Amato's 8:30 AM ET Tread Class was canceled. It has been rescheduled for 9:00 AM ET.
Posted May 04, 2020 - 08:59 EDT
This incident affected: Bike/Tread/Digital (Live Classes).