Issue with Live Classes
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jan 29, 2023 - 16:24 EST
Investigating
We are investigating an issue with Peloton class streaming. This may impact your ability to take live classes.
Posted Jan 29, 2023 - 14:01 EST
This incident affected: Bike/Tread/App/Row (Live Classes).