New Account Creation Issues
Incident Report for Peloton
Resolved
This issue with creating new Member accounts Iwas resolved.
Posted May 29, 2020 - 14:13 EDT
Investigating
We are currently investigating an issue creating new member accounts - existing member accounts are not affected. Our team will update this page with new information.
Posted May 28, 2020 - 21:23 EDT
This incident affected: Bike/Tread/Digital (Member Login).