Live and On-Demand Leaderboard

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Feb 18, 2022 - 17:28 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2022 - 15:52 EST

Investigating

We are investigating an issue with the Leaderboard. This may impact your ability to view, sort, or track your output on the Leaderboard during a live or on-demand class. This may impact the class history data that is posted for workouts during this time.
Posted Feb 18, 2022 - 15:45 EST
This incident affected: Bike/Tread/App/Row (Leaderboard).