Continued Phone Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 12, 2019 - 17:48 EDT
Monitoring
We've seen full recovery for assignment of calls. We will continue to monitor and provide further updates when we are certain of resolution.
Posted 2 months ago. Aug 12, 2019 - 16:45 EDT
Identified
We apologize, but we are currently experiencing an issue with receiving calls to our Support team. Our team is available to help immediately over chat at support.onepeloton.com if you need assistance.
Posted 2 months ago. Aug 12, 2019 - 15:32 EDT
This incident affected: Website (Peloton Studio (studio.onepeloton.com)).