Issue with accessing Peloton Platform

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Mar 09, 2023 - 14:33 EST

Monitoring

A fix has been implemented to resolve the login issue. Please try logging in again to access your account. We are monitoring the status. We apologize for any interruption to your workout.
Posted Mar 09, 2023 - 13:24 EST

Update

We are continuing to investigate this issue.
Posted Mar 09, 2023 - 12:33 EST

Update

We are investigating an issue with Peloton’s platform. This may impact your ability to log in and access Peloton classes.
Posted Mar 09, 2023 - 12:20 EST

Investigating

We are investigating an issue with Peloton class streaming. This may impact your ability to take live classes.
Posted Mar 09, 2023 - 12:14 EST