Incoming Phone Call Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Nov 06, 2019 - 13:33 EST
Monitoring
Previous issues with incoming calls to our support and sales team should now be resolved and we are continuing to monitor for any further issues.
Posted Nov 06, 2019 - 13:11 EST
Identified
We are currently experiencing issues connecting incoming phone calls to our support agents. We apologize for any problems this may cause. We recommend contacting our support team from the chat function on our support site at https://support.onepeloton.com
Posted Nov 06, 2019 - 13:02 EST
This incident affected: Website (Peloton Support (support.onepeloton.com)).