Members are reporting issues during scheduled rides, sessions, and rides with friends including metrics failing to display.

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 13:19 EDT

Investigating

The issue has been identified, and a fix will be rolling out starting on 4/13.
Posted Apr 08, 2026 - 14:25 EDT