Phone Line Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted 23 days ago. Sep 26, 2019 - 15:13 EDT
Investigating
We are currently investigating an issue with our phone system where reaching certain numbers, particularly retail locations, is not working. We will update this site as we receive updated information.
Posted 23 days ago. Sep 26, 2019 - 14:58 EDT