The tags service is currently down resulting in user profiles not displaying tags, inability to filter the leaderboard by tags, and an empty activity feed.

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 11:02 EDT

Identified

The issue has been identified and is being fixed.
Posted Jul 29, 2025 - 10:11 EDT
This incident affected: Bike/Tread/App/Row (Leaderboard).