Unable to start classes on App and Web - Class Details Page Unavailable across all platforms

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 20:08 EST

Monitoring

Members are able to start classes on App, Web and Guide and Class Details are now loading. Team is monitoring.
Posted Jan 21, 2026 - 19:37 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 21, 2026 - 19:24 EST
This incident affected: Bike/Tread/App/Row (Peloton App).