Issue with Viewing and Playing Classes
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted May 11, 2023 - 11:39 EDT
Monitoring
The data center has reported they are seeing recovery and service has returned to normal. We apologize for any interruption to your workout.
Posted May 11, 2023 - 08:56 EDT
Investigating
We are investigating an incident with a small number of members who are having trouble viewing and playing classes due to a broader data center outage. We apologize for any interruption to your workout.
Posted May 11, 2023 - 08:45 EDT
This incident affected: Bike/Tread/App/Row (Live Classes, On Demand Classes).