Some returning App members are unable to apply the New Years promotional code.
Incident Report for Peloton
Identified
Returning members can receive the New Year's promotion by signing up at https://www.onepeloton.com/app-membership using their previous account e-mail address.
Posted Jan 08, 2025 - 16:14 EST
Investigating
The team is actively investigating.
Posted Jan 06, 2025 - 13:03 EST
This incident affects: Bike/Tread/App/Row (Peloton App).