Australia phone numbers not receiving calls
Incident Report for Peloton
Resolved
We've identified the issue and our phone lines are operating normally. We apologize for the inconvenience.
Posted Aug 29, 2022 - 07:01 EDT
Investigating
We are investigating an issue where we are unable to receive phone calls in Australia. If you need immediate assistance, please chat with us on support.onepeloton.com.
Posted Aug 29, 2022 - 06:34 EDT
This incident affected: Contact (Phone).