Live and On Demand Classes
Incident Report for Peloton
Resolved
The performance issues with accessing live & on-demand Peloton classes on the Bike, Tread, and App have now been resolved. The team is continuing to monitor the situation. We apologize for the inconvenience.
Posted Mar 13, 2020 - 17:20 EDT
Monitoring
We are beginning to see recovery with the issues with accessing live & on-demand Peloton classes on the Bike, Tread and App. Our team will continue to monitor the situation until it is resolved.
Posted Mar 13, 2020 - 17:00 EDT
Investigating
We are investigating an issue with Peloton classes and accessing onepeloton.com. This may impact your ability to take live or on-demand classes.
Posted Mar 13, 2020 - 16:46 EDT
This incident affected: Bike/Tread/Digital (Member Login, Live Classes, On Demand Classes, Leaderboard, Activation) and Website (Peloton Site - US (onepeloton.com), Peloton Site - Canada (onepeloton.ca), Peloton Site - UK (onepeloton.co.uk), Peloton Site - Germany (onepeloton.de), Member Profile/Workout History (members.onepeloton.com)).