UK Streaming Issues
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 13:06 EDT
Investigating
Our team is investigating an issue where members in the UK are having issues with streaming workouts. We will update this page with further information.
Posted Mar 17, 2020 - 11:13 EDT
This incident affected: Bike/Tread/Digital (Live Classes, On Demand Classes).