Issue with Scheduling Delivery
Incident Report for Peloton
Resolved
The issue with scheduling deliveries has been resolved.
Posted Oct 28, 2022 - 16:15 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 21, 2022 - 19:14 EDT
Investigating
We are currently investigating an issue impacting the ability to schedule a delivery for recently completed purchases.
Posted Oct 21, 2022 - 18:21 EDT
This incident affected: Website (Peloton Checkout (onepeloton.com/checkout)).