Workout dot not reflecting workout taken

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Nov 12, 2024 - 09:05 EST

Update

The data backfill has been completed and team continues to monitor. Members should now see their workouts reflected correctly on their homepage.
Posted Nov 10, 2024 - 14:29 EST

Update

The team is still actively working to complete the data backfill, though it’s taking longer than we initially expected. We're now aiming to have everything fully resolved by Monday morning if not sooner.
Posted Nov 09, 2024 - 09:24 EST

Monitoring

Team has resolved the issue and for workouts taken going forward member's dot will now reflect correctly. Team is working to backfill the data that was missed during this time, this is still in progress and all the data should be recovered by Saturday evening.
Posted Nov 07, 2024 - 11:19 EST

Investigating

Team is aware of an issue with the workout dot not reflecting after a workout and is investigating
Posted Nov 07, 2024 - 09:35 EST
This incident affected: Bike/Tread/App/Row (Peloton App, Connected Fitness Tablets) and Website (Peloton Profile/Workout History (members.onepeloton.com)).