Call Routing Issue
Incident Report for Peloton
Resolved
The routing issue with our phone system has been resolved.
Posted Sep 20, 2021 - 17:31 EDT
Monitoring
A fix has been implemented for our Phone platform and we are monitoring the results.
Posted Sep 20, 2021 - 13:12 EDT
Investigating
We are investigating an issue with our Phone platform that is preventing some incoming calls from routing to our associates. Please visit our support page at support.onepeloton.com to chat with one of our associates.
Posted Sep 20, 2021 - 11:14 EDT
This incident affected: Contact (Phone).