SkyTv Platform
Incident Report for Peloton
Resolved
The issue with the SkyTv Peloton App that impacted access has been resolved.
Posted Mar 30, 2023 - 13:12 EDT
Update
The issue with the SkyTV Peloton App that impacted access has been resolved.
Posted Mar 30, 2023 - 13:10 EDT
Investigating
Members are reporting issues accessing the SkyTV Peloton app. We are currently investigating this issue.
Posted Mar 23, 2023 - 20:51 EDT
This incident affected: Bike/Tread/App/Row (Peloton App).