Degraded performance for Members using "Three" network in the UK
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 14:17 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 13, 2020 - 09:07 EDT
Investigating
We are aware that Members using Three network in the UK may be experiencing degraded streaming performance and we are working to resolve the issue
Posted Aug 13, 2020 - 09:06 EDT
This incident affected: Bike/Tread/App/Row (Live Classes, On Demand Classes).