Android Members: logging a just workout is not properly displaying location data

Incident Report for Peloton

Update

The issue has been identified as team works on implementing a fix.
Posted Apr 06, 2026 - 15:10 EDT

Identified

The issue has been identified as team works on implementing a fix.
Posted Apr 06, 2026 - 12:25 EDT

Investigating

Team is actively investigating this Android issue.
Posted Apr 06, 2026 - 11:26 EDT
This incident affects: Bike/Tread/App/Row (Peloton App).