Members who complete a workout with the Android Watch paired and remain on the workout summary will observe an app crash.

Incident Report for Peloton

Resolved

This incident has been resolved and a new app version has been rolled out. Download the latest v.3.75.1 to fix this!
Posted Aug 17, 2026 - 16:18 EDT

Identified

Members who complete a workout with the Android Watch paired and remain on the workout summary screen on the watch will observe a crash if they leave the peloton watch app on that screen.
Posted Aug 14, 2026 - 11:57 EDT
This incident affected: Bike/Tread/App/Row (Peloton App).