Live and On Demand Classes
Incident Report for Peloton
Resolved
The performance issues with the Leaderboard have now been resolved. We apologize for any issues that you may have experienced this morning.
Posted 3 months ago. Apr 24, 2019 - 08:59 EDT
Investigating
We are investigating an issue with Peloton classes. This may impact your ability to take live or on-demand classes.
Posted 3 months ago. Apr 24, 2019 - 07:13 EDT
This incident affected: Bike/Tread (Live Classes, On Demand Classes).