Live and On Demand Classes in the UK and Germany
Incident Report for Peloton
Resolved
This issue has now been resolved. If you are still experiencing issues streaming Peloton content, please contact our Member Support team on 0808 169 6469 (UK) / 0800 0010028 (DE)
Posted Nov 06, 2020 - 11:50 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 06, 2020 - 03:43 EST
Monitoring
A fix has been implemented and we are monitoring performance. If you continue to experience persistent buffering on on-demand rides, please contact our Member Support team on:
+44 808 1696469 (UK)
+49 800 0010028 (DE)
Posted Nov 06, 2020 - 03:42 EST
Identified
We have identified an issue with Peloton classes in the UK & Germany and we are working to resolve it. This may impact your ability to take live or on-demand classes. We appreciate your patience at this time and we are working hard to get you back up and riding as quickly as possible!
Posted Oct 28, 2020 - 09:03 EDT
Investigating
We are investigating an issue with Peloton classes in the UK & Germany. This may impact your ability to take live or on-demand classes. We appreciate your patience at this time and we are working hard to get you back up and riding as quickly as possible!
Posted Oct 25, 2020 - 12:26 EDT
This incident affected: Bike/Tread/App/Row (Live Classes, On Demand Classes).