Special Pricing Verification

Incident Report for Peloton

Resolved

This incident has been resolved. Members are able to verify their status via id.me to receive AppOne + CFU discounts.
Posted Dec 09, 2024 - 09:59 EST

Monitoring

id.me has rolled out a fix for this issue and is monitoring
Posted Dec 09, 2024 - 09:14 EST

Identified

Our partner id.me has identified an issue which is currently preventing our members from verifying their status for special pricing of our CFU products and AppOne subscription.
Posted Dec 08, 2024 - 21:50 EST