Teams Page Not Loading
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 11:40 EDT
Monitoring
We have mitigated the issue and are monitoring, Teams functionality is available again
Posted Sep 18, 2024 - 09:27 EDT
Investigating
We are investigating an issue with loading the Teams feature, Teams are currently unavailable.
Posted Sep 18, 2024 - 09:16 EDT
This incident affected: Bike/Tread/App/Row (Peloton App).