Live and On Demand Classes
Incident Report for Peloton
Resolved
We identified and resolved the issue that prevented you from logging in. You should now be able to log in and take a class.
Posted about 1 month ago. Mar 14, 2019 - 18:52 EDT
Investigating
We are currently experiencing technical issues on our end that prevent you from logging into your account or taking live or on-demand classes. Our team is working to resolve this issue as soon as possible.
Posted about 1 month ago. Mar 14, 2019 - 18:36 EDT
This incident affected: Bike/Tread (Live Classes, On Demand Classes).