Live and On Demand Classes
Incident Report for Peloton
Resolved
This incident has been resolved. We apologize for any interruptions this may have caused to your workout.
Posted Oct 07, 2020 - 18:56 EDT
Identified
A small number of Members have reported issues joining a live or on demand class on their Peloton Bike. We’ve identified the issue and are working on a fix. In the meantime, Members can resolve the issue by updating their touchscreen:
- Tap on “Settings” on the top right corner of the touchscreen
- From the dropdown menu, select “Device Settings”
- Scroll down to “System” and select “About Tablet”
- Tap on “System Updates”
- Once you tap on “System Updates” the touchscreen will inform you of your “Software Update Status”
- If your Software is not up-to-date, the touchscreen will inform you that there is an update available and will prompt you to update to the latest software version
Posted Oct 07, 2020 - 14:06 EDT
This incident affected: Bike/Tread/Digital (Live Classes, On Demand Classes).