Class Failing to Load for Some Members across Peloton surfaces

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 10:02 EDT

Monitoring

Team has mitigated the issues and members should now be able to resume taking on-demand classes. Team will continue to monitor systems.
Posted Oct 09, 2025 - 17:27 EDT

Identified

Team is seeing issues across the experience and is investigating
Posted Oct 09, 2025 - 16:29 EDT

Monitoring

Team has mitigated the issues and members should now be able to resume taking on-demand classes. Team will continue to monitor systems.
Posted Oct 09, 2025 - 16:07 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 09, 2025 - 15:33 EDT

Identified

Team has identified is is an issue with our on-demand classes and is working on a fix, members are still unable to take on demand video classes at this time. Live Classes, Audio Classes and Just Workout are unaffected by this outage.
Posted Oct 09, 2025 - 13:59 EDT

Investigating

The team is currently investigating the issue.
Posted Oct 09, 2025 - 13:41 EDT
This incident affected: Bike/Tread/App/Row (On Demand Classes).