We are investigating an incident with Peloton's services
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jul 05, 2023 - 14:35 EDT
Investigating
We are investigating an issue with Peloton's Chat and Phone services. We will provide an update when we have more information available. We apologize for any inconvenience.
Posted Jul 05, 2023 - 13:18 EDT
This incident affected: Contact (Phone, Chat).