Issue with Checkout
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jan 25, 2022 - 10:54 EST
Monitoring
A fix has been implemented for financing purchases using Affirm, and we are monitoring the results.
Posted Jan 24, 2022 - 12:38 EST
Update
A fix has been implemented for financing purchases using Affirm in the US, and we are monitoring the results. We are continuing to investigate an issue with financing purchases using Affirm in Canada. We recommend trying to make your purchase later today. We apologize for any inconvenience.
Posted Jan 24, 2022 - 11:57 EST
Investigating
We are investigating an issue with financing purchases using Affirm. We recommend trying to make your purchase later. We apologize for any inconvenience.
Posted Jan 24, 2022 - 10:44 EST
This incident affected: Website (Peloton Site - US (onepeloton.com), Peloton Site - Canada (onepeloton.ca)).