Degraded Checkout Experience with Affirm

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 11:55 EST

Identified

Due to a widespread infrastructure outages we are seeing degraded checkout experience with our financing partner affirm.
Posted Nov 18, 2025 - 09:21 EST
This incident affected: Website (Peloton Site - (onepeloton.com)).