Flashing Touchscreens on New Bike and Tread Deliveries
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 11:21 EST
Monitoring
We've released a fix for this issue and touchscreens and we are monitoring the release to ensure this completely resolves the issue.
Posted Feb 23, 2021 - 10:35 EST
Investigating
A small number of Members are reporting an issue where their touchscreens are unresponsive and flash white immediately upon delivery. We are aware of the issue and are investigating a fix.

If you are experiencing this issue, we recommend putting the touchscreen to sleep for 1 minute and turning the screen back on.Existing Peloton Members are not impacted by this issue.
Posted Feb 23, 2021 - 09:04 EST
This incident affected: Bike/Tread/App/Row (Activation).