Member Login Issue
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Jul 14, 2022 - 16:48 EDT
Monitoring
A fix has been implemented to resolve the login issue. If you are still having issues accessing your Bike/Tread, we recommend restarting your device. We apologize for any interruption to your workout.
Posted Jul 14, 2022 - 14:00 EDT
Investigating
Our Team is investigating an issue that is impacting Members' ability to log in to their account and access workouts.
Posted Jul 14, 2022 - 13:38 EDT
This incident affected: Bike/Tread/App/Row (Member Login).