Intermittent crash identified on iOS Apple Watch

Incident Report for Peloton

Identified

This issue has been identified and we are investigating a fix.
Posted Sep 09, 2026 - 12:27 EDT

Investigating

We are investigating an ongoing issue with the Apple Watch connecting to a workout and the app crashing intermittently. Team is investigating.
Posted Sep 09, 2026 - 10:13 EDT
This incident affects: Bike/Tread/App/Row (Peloton App).