Issue with Scenic Classes Loading
Incident Report for Peloton
Resolved
The performance issues with scenic classes have now been resolved.
Posted Jul 01, 2019 - 14:23 EDT
Investigating
We are investigating an issue with Peloton scenic classes. This may impact your ability to take scenic classes.
Posted Jul 01, 2019 - 13:04 EDT
This incident affected: Bike/Tread (On Demand Classes).