Onepeloton.com Degraded Performance
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Oct 08, 2020 - 16:40 EDT
Identified
We've identified the issue and are starting to see recovery. We appreciate your understanding as the team works to resolve this issue.
Posted Oct 08, 2020 - 15:27 EDT
Investigating
We are currently investigating an issue with onepeloton.com and members.onepeloton.com loading
Posted Oct 08, 2020 - 15:09 EDT
This incident affected: Website (Peloton Site - US (onepeloton.com), Peloton Site - Canada (onepeloton.ca), Peloton Site - UK (onepeloton.co.uk), Peloton Site - Germany (onepeloton.de), Member Profile/Workout History (members.onepeloton.com)).