Some members setting up their Tread+ may encounter a crash loop.
Incident Report for Peloton
Resolved
This incident has been resolved.
Posted Oct 21, 2024 - 11:41 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 10, 2024 - 20:50 EDT
Identified
The issue has been identified, and the team is working on a resolution.
Posted Oct 10, 2024 - 08:30 EDT
Investigating
We are currently investigating this issue.
Posted Oct 09, 2024 - 21:46 EDT
This incident affected: Bike/Tread/App/Row (Connected Fitness Tablets).