Community Feed (iOS & Android) may see missing workouts that unlocked a Peloton Badge.

Incident Report for Peloton

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 17:12 EST

Monitoring

A fix has been implemented and we are monitoring the results
Posted Mar 04, 2026 - 11:09 EST

Identified

Members who access the Community Feed (on iOS & Android) may see an issue where workouts that have unlocked a Peloton badge may not be appearing on the feed for themselves and/or Members they are following. Team is actively investigating a fix and root cause.
Posted Mar 02, 2026 - 15:15 EST
This incident affected: Bike/Tread/App/Row (Peloton App).